Compatibility

For an optimal experience we recommend using Chrome although Kigo is supported by IE8+ and the latest versions of Firefox and Safari.

 

Some of the features might not work correctly on IE6/7 which is not supported by Kigo.

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.
Powered by Zendesk